Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

28.01.2005, 12:11

[gelöst] GCC 3.3.5 und jpeg-6b-r4

Ich ihabe gerade mein Gentoosystem neuinstalliert mit dem Kernel 2.6.10-gentoo-r6 und GCC 3.3.5, nun habe ich xorg installiert und getestet - läuft. Jetzt stehe ich bei der Installation von kde (kdebase, kdeadmin, kdeartwork), da es ein Compilerproblem gibt, das sicher nicht an den USE-Flags liegt (es tritt immer an der gleichen Stelle der glecihe Fehler auf). Der Fehler wird durch die jpeg-6b-r4 Lib verursacht,. es sieht so aus, als läge das Problem an GCC 3.3.5, eine neuere Version von jpeg habe ich nicht gefunde, hier die genaue Fehlermeldung:

Quellcode

1
2
3
4
5
g++: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/.../crtio.o: No such file or directory
g++: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/crtbeginS.o: No such file or directory
g++: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/crtend.o: No such file or directory
g++: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/.../crtn.o: No such file or directory
make *** [libjpeg.la] Fehler 1


Ich brauche dringend Hilfe, da es vielleicht ja sogar ein globales GCC Problem ist und ich brauche das System zum Arbeiten. Danke für jede Hilfe, wie immer, im Vorraus ;)

mfG, Ruffy

EDIT:
Habe im engl. Forum etwas dazu gefunden, führe deren Befehle aus, das wird sehr lange dauern, seht euch das mal bitte an und sagt mir (schreibt hier für alle ;) ), ob diese Möglichkeit gut ist oder ob es schneller bzw. bequemer geht.

http://forums.gentoo.org/viewtopic.php?t…&highlight=jpeg
***Don't dream ya life, live ya dreams ***

Athlon 64 3500+ (Venice), 2GB DDR400, 2x 250GB S-ATA (Raid 0), 1x 80GB S-ATA, GeForce 6800GT@Ultra, SB Audigy 2, ASUS A8N-SLI Premium

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »ruffy« (31.01.2005, 18:25)


2

29.01.2005, 17:11

Zitat

EDIT:
Habe im engl. Forum etwas dazu gefunden, führe deren Befehle aus, das wird sehr lange dauern, seht euch das mal bitte an und sagt mir (schreibt hier für alle Augenzwinkern ), ob diese Möglichkeit gut ist oder ob es schneller bzw. bequemer geht.

http://forums.gentoo.org/viewtopic.php?t...&highlight=jpeg


Erstmal danke dafür!
Wollte gestern mein System mittels emerge -e world rekompilieren und als ich dann bei der Installation libjpeg,
angestoßen bin kam ich den selben Fehler.
Dein Link hat mir da weitergeholfen.
Allerdings recihte bei mir ein:

Quellcode

1
emerge -e system && emerge --depclean && emerge -e system && emerge -e world


Gruß

RedWing

3

31.01.2005, 18:25

Ich habe es ebenfalls verkürzt, ist mir auch aufgefallen, dass die gepostete Lösung doppelt gemoppelt ist ;)

Ich verwende nun:

Quellcode

1
emerge -e system && emerge --depclean && emerge -e world

mfG, Ruffy
***Don't dream ya life, live ya dreams ***

Athlon 64 3500+ (Venice), 2GB DDR400, 2x 250GB S-ATA (Raid 0), 1x 80GB S-ATA, GeForce 6800GT@Ultra, SB Audigy 2, ASUS A8N-SLI Premium

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »ruffy« (01.02.2005, 21:27)