Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

14.03.2005, 15:57

cedega + battlefieldvietnam + performance

hallo leute,

ich versuche seit einigen tagen bfv auf meiner gentoobox vernünftig (spielbar) zum laufen zu bekommen. zunächst mal meine hw:

athlon xp mobile @2200mhz
1 gb ram
asus a7n8x deluxe (nforce2)
nvidia 6800le@irgendwas (auf jeden fall mehr als vorher)

der rest sollte mehr oder weniger egal sein.... :)

ich kann das spiel ganz normal starten (benutze dazu point2play), dabei ruckelt auch noch nichts. wenn ich aber ein spiel betrete (single/multi), wird es unspielbar. dabei ist die darstellung/sound aber 1A. "lediglich" die performance lahmt, was man auch daran bemerken kann, dass der bildaufbau "diashowmässiger" wird, je mehr action auf dem screen geboten wird.

habt ihr einen tip? habe mich dabei an die installationsanleitung von www.holarse.net
gehalten.
die grafikeinstellungen stehen dabei auf 1280x1024, höchste detailstufe. habs noch nicht mit einer reduzierung der details getestet (werde ich noch heute machen), macht aber den eindruck, als ob das nix bringen wüde.

grz
hal2050

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »hal2050« (21.09.2007, 00:21)


2

14.03.2005, 16:16

http://liflg.org/?catid=7&gameid=20
Probier mal diese Cedega-Einstellungen und im Notfall mal den Installer.
Alles muss im Überfluss vorhanden sein, dann sind wir nie allein.

3

14.03.2005, 16:42

jo hab ich schon...http://www.holarse.de/?content=/emulatio…piele/bfvietnam
beschreibt die installation eben genau so, d.h. loki installer benutzen, und dann...

""Fügt folgene Zeilen in eure Wine Config ein (~/.wine/config bzw. ~/.transgaming/config):

;; Battlefield Vietnam settings
[AppDefaults\bfvietnam.exe\d3dgl]
"ClipSpaceFix" = "N"

Anschließend müsst ihr in der Wine Regestry noch folgendes eintragen (~/.wine/system.reg bzw. ~/.transgaming/system.reg):

[Software\EA GAMES\Battlefield Vietnam]
"LANGUAGE"="*SPRACHE*"

*SPRACHE* müsst ihr duch eine der folgenden ersetzen:

Chinese
English
French
German
Italian
Japanese
Korean
Spanish
""

point2play benutze ich dabei nur um einen ýberssichtlichen "starter" zu haben, der mir alle games auflistet.

grz
hal2050

4

15.03.2005, 09:39

...funzt jetzt. vertex ram war wohl in der config über point2play zu niedrig eingestellt.
habs nun auf 64mb gestellt, danach liefs. vorher hab ich allerdings das cedega 4.3 emerged, daher kann ich nicht sagen ob, das bei der 4.2er version auch das problem war.
sieht zwar gut aus, kommt aber leider nicht an die geschwindigkeit ran, wenn´s auf einer win platform laufen würde.

grz
hal2050

5

15.03.2005, 13:48

ist ja auch nunmal ne art "emulation" und ich würd sagen fast alles was nicht für linux gedacht ist sondern für win und du es mit wine/cedega starten musst wird nicht so laufen wie unter win
Gentoo Linux / gentoo-sources 2.6.24-r4 / Gnome + Compiz Fusion + Emerald ;-)
Nexoc Osiris S602 / Pentium M 1,4GHZ / 1024 MB RAM / Intel 855GME 64 MB

6

15.03.2005, 20:40

jo denk ich auch. aber da ja linux das wesentlich ressourcen sparendere system ist, waere es ja gut moeglich dass genau diese freien ressourcen das wieder ausgleichen koennten.

ich hab jetzt noch ein bisschen "rumgeschraubt", so dass ich im singleplayer eine, naja sagen wir mal, durchschnittliche fps rate von 35 habe. und wenn ich ehrlich bin ist der unterschied zu win fast nicht mehr spuerbar, wenn ueberhaupt. was ich gemacht habe?

1. bfv mit loki installer installiert ->http://liflg.org/?catid=7&gameid=20

2. bfv mit loki installer upgedated -> http://liflg.org/?catid=7&gameid=20

3. bfv mit loki installer upgedated -> http://liflg.0wnitsch.de/files/testing/b…uage.update.run

4. bfv mit loki patch gepatched -> http://liflg.0wnitsch.de/files/testing/4LMP/LMP.tar.gz
(3./4. gibts auch hier zum nachlesen http://www.liflg.org/forum/viewtopic.php?t=52)

(5.) PunkBuster Patch, ich denke bei MP zu empfehlen, noch nicht getestet -> http://transgaming.org/forum/viewtopic.php?t=1065

6. einige files laut www.holarse.net erstellt bzw veraendert -> http://www.holarse.de/?content=/emulatio…piele/bfvietnam

7. cedega 4.3 emerged, point2play 1.2.1 behalten, da ich keine point2play small 1.3 fuer portage gefunden hab.

9. einstellungen fuer agp, fastwrites, alsa optimiert und einige tweaks fuer hl2 benutzt->http://www.linux-gamers.net/modules/wfse…hp?articleid=60

10. die options fuer bfv in point2play auf folgende settings gesetzt:

win98 oder me, bei me kommts mir ein stueckchen butterweicher vor 8o...fuer irgendwas musste ja winme gut sein *hehe*, hatte schon fast vergessen dass es die pappschachtel mal gab.

pixelshader 1.3
videoram 128
agp ram 64
pthreads yes
cedega default
der rest auf standard settings

11. 1280x1024x32+fulldetail=/35fps

12. nach einer loesung suchen, die es mir ermoeglicht auf 1.21 upzudaten. wenn ich das ueber
cedega bzw p2p mache, wird die installation nicht gefunden und die installation bricht ab.
dann koennte ich, wahrscheinlich in verbindung mit punkt (5.), evtl auch wieder online zocken :D

wenn hier noch jmd ne loesung kennt,... 8)

grz
hal2050

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »hal2050« (15.03.2005, 20:41)


7

21.03.2005, 11:01

m´k 8) habe das problem nun anders gelöst.
zunächst hab ich den kompletten kram mit dem loki_uninstaller wieder gelöscht.
anschliessend das game per point2play installiert. danach hat die kiste auch nicht
mehr über updates gemeckert. die cedega einstellungen habe ich nicht verändert, benutze die selben settings wie vorher auch schon (s.o.).
...jetzt kann ich auch wieder onlinematches zocken und somit eigentlich meine winplatte
platt machen :D

grz
hal2050

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »hal2050« (21.03.2005, 11:03)