Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

15.03.2005, 20:45

[gelöst] America's Army 2.3.0 Problem

Hallo erstmal.

Also es sind mehr oder weniger zwei Probleme:


Das eine ist, dass es nur in 800*600 und 16bit (???) läuft, also richtig schrecklich.

und in der Konsole steht folgendes:

Quellcode

1
Xlib:  extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0".


hat das damit was zu tun, wenn ja, wie bekomm ich das in Ordnung?




Das andere Problem ist, dass das irgendwie nich online-spielbar ist. Es versucht PB abzudaten, aber das kann ich 5h laufen lassen und da passiert nix, als gui wird in der Konsole auch nur ein "?" angezeigt. Was is da nicht richtig?



Für Hilfe immer dankbar:

Apollo
In jedem noch so reinen Herzen existiert ein Ort des tiefsten Abgrundes. (C) Apollo '02

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Apollo« (17.03.2005, 01:18)


2

17.03.2005, 00:02

So,

also ich hab dann doch mal google.de bedient und habe in einem GAmeStar Forum was gefunden:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
 (Muss hierzu in dein ArmyOps Verzeichnis wechseln)
ln -s /usr/lib/libGL.so.1
ln -s /usr/lib/libGLcore.so.1

anschließend ein:

LD_PRELOAD=/usr/lib/tls/libGL.so.1

und startest das Game wieder mit
armyops
Mit Zitat antworten


Das gute daran ist, ich konnte endlich zocken und das interne pb-update hat auch geklappt :)

Das andere...die fehlermeldung steht immer noch da und ich kann die Auflösung nicht auf 1024*768 hochsetzen und die Farbtiefe ist bei 16bit oder drunter.



Wer was weis bitte posten *g*


Apollo,

der auch selber noch weitersucht :)
In jedem noch so reinen Herzen existiert ein Ort des tiefsten Abgrundes. (C) Apollo '02

3

17.03.2005, 01:17

So,

also die Sache ist jetzt die:

ES läuft!!!! :)

ich hab in der xorg.conf einfach die default fabrtiefe auf 24bit hochgesetzt, und schon konnte ich in America's Army auch 1024*768 auswählen :D


hmm das einzigste was jetzt immer kommt, bzwn nach dem Spiel beenden in der Konsole steht ist

Quellcode

1
Received invalid actor class



nuja aber das spiel läuft 1a *freuz*



Apollo
In jedem noch so reinen Herzen existiert ein Ort des tiefsten Abgrundes. (C) Apollo '02

4

25.03.2005, 13:52

wie kommt es, dass du aa 2.3 installiert hast, in portage finde ich nur die version 221, oder hast du es nicht in portage installiert?

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Atahualpa« (25.03.2005, 13:53)


5

25.03.2005, 13:55

Nö, ich hab mir das von der Homepage von AAO gezogen. Und da in meinem Home-Bereich installiert. Das muss nich irgendwie an das System angepasst werden. :)

Also bei mir funzt das 1a und besser als unter Win ;)



mfg


Apollo
In jedem noch so reinen Herzen existiert ein Ort des tiefsten Abgrundes. (C) Apollo '02

6

25.03.2005, 14:01

und du hast es einfach über sh armyops230-linux.run installiert?

wie würdest du es wieder deinstallieren?

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Atahualpa« (25.03.2005, 14:01)


7

25.03.2005, 14:04

zum deinstallieren befindet sich dann auch ein script in dem verzeichnis ;)
In jedem noch so reinen Herzen existiert ein Ort des tiefsten Abgrundes. (C) Apollo '02

8

25.03.2005, 14:28

da steht in der README :)

Quellcode

1
2
3
4
5
6
If you have a previous version installed, you need to
uninstall it before installing this version. There is
a script in the game's directory called "uninstall"
for this purpose. Alternately, you can delete the
game's directory and (as the user who installed the
game) ~/.loki/installed/armyops.xml ...


:)
In jedem noch so reinen Herzen existiert ein Ort des tiefsten Abgrundes. (C) Apollo '02

9

25.03.2005, 14:54

so, wollte das spiel starten und bekomme :

atahualpa@tux americas-army $ armyops
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Signal: SIGSEGV [segmentation fault]
Aborting.


Crash information will be saved to your logfile.
X Error of failed request: BadColor (invalid Colormap parameter)
Major opcode of failed request: 79 (X_FreeColormap)
Resource id in failed request: 0x40000c
Serial number of failed request: 120
Current serial number in output stream: 122
atahualpa@tux americas-army $

hast du eine Vermutung, woran das liegen könnte?

10

25.03.2005, 19:25

hmm...hast du in deiner xorg.conf das GLX modul aktiviert?....normalerweise ist das auskommentiert mit einem # mach den einfach mal weg :)
In jedem noch so reinen Herzen existiert ein Ort des tiefsten Abgrundes. (C) Apollo '02

11

26.03.2005, 11:14

glx ist schon drin, aber da gab es einen konflikt mit der Extension für Schatten und Transparenz.
Jedoch komme ich gar nicht mehr dazu, diesen zu lösen, da ich mich nicht mehr mit kdm als benutzer anmelden kann.