Sie sind nicht angemeldet.

1

27.05.2003, 01:57

Realtek 8139 & pcmcia

Hallo, ich versuche gerade Gentoo 1.4rc4 auf meinem Toshiba Tecra 8000 zu installieren und hänge bei der Netzwerkkonfiguration fest. Die pcmcia-Treiber habe ich beim Start schon geladen (dopcmcia). Will ich nun das 8139too-Modul laden bekomme ich die Fehlermeldung:
8139too: region #1 not an MMIO resource, aborting

Kann mir jemand weiterhelfen?

mfG Stef

2

27.05.2003, 11:55

Welchen kernel hast du genommen ?
ACPI aktiviert ? APIC drinne ?
- :: AMD XP 2500+ :: Gentoo :: -
www.Unixboard.de - German Linux Community
www.Gentooforum.de - German Gentoo Community

3

27.05.2003, 12:18

Zitat

Original von devilz

Welchen kernel hast du genommen ?
ACPI aktiviert ? APIC drinne ?


Hallo, der Kernel ist : Linux version 2.4.20-xfs-r2 (root@ToyRoom) (gcc version 3.2.1 20021207 ....) (Ausgabe von cat /proc/version)

mit ACPI hab ich schon probiert ... ging auch net (natürlich auch ohne probiert)

beim Starten gibt er auch auch schon folgenede Fehler aus:
[code:1]Starting USB and PCI hotplugging ...
pcilib: Cannot open /proc/bus/pci/15/00.0 (diese Zeile 9x)[/code:1]

Ich habe natürlich mit der Option dopcmcia gestartet und die beiden Controller werden auch erkannt.

Gruß Stef

4

27.05.2003, 18:58

Ich denke, du solltest es mit pcmcia-cs versuchen. Welche Karten da unterstuetzt sind, kannst du hier: url=http://pcmcia-cs.sourceforge.net/ftp/SUPPORTED.CARDS nachlesen.

Alex
http://spitfire.homelinux.net/
http://spitfire.spittix.de/

GNU/LinuX mobile Dokumentation

5

28.05.2003, 01:06

Zitat

Original von ajordan

Ich denke, du solltest es mit pcmcia-cs versuchen. Welche Karten da unterstuetzt sind, kannst du hier: url=http://pcmcia-cs.sourceforge.net/ftp/SUPPORTED.CARDS nachlesen.

Alex


Hallo,

meine Karte steht leider nicht in der Liste ... ich habe eine MENTOR PCMLAN 100PRO und das einzige was ich sicher weiss, ist das sie den 8139 von Realtek drauf hat.

vielleicht helfen ja folgende Infos:

lspci

Zitat

pcilib: Cannot open /proc/bus/pci/15/00.0
Unable to read 64 bytes of configuration space.
00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (AGP disabled) (rev 03)
00:04.0 VGA compatible controller: Neomagic Corporation NM2200 [MagicGraph 256AV] (rev 12)
00:05.0 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
00:05.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
00:05.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
00:05.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
00:09.0 Communication controller: Toshiba America Info Systems FIR Port (rev 23)
00:0b.0 CardBus bridge: Toshiba America Info Systems ToPIC97 (rev 05)
00:0b.1 CardBus bridge: Toshiba America Info Systems ToPIC97 (rev 05)

cardctl ident

Zitat

Socket 0:
product info: "PC CARD", "56Kbps Fax Modem PC Card", "5.41"
manfid: 0x014e, 0x0088
function: 2 (serial)
Socket 1:
product info: "Realtek", "Rtl8139"
manfid: 0x0000, 0x024c
function: 6 (network)
PCI id: 0x10ec, 0x8139

dmesg

Zitat

Linux version 2.4.20-xfs-r2 (root@ToyRoom) (gcc version 3.2.1 20021207 (Gentoo Linux 3.2.1-20021207))
#1 Thu Apr 10 02:24:31 Local time zone must be set--see zic manu
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000000fff0000 (usable)
BIOS-e820: 000000000fff0000 - 0000000010000000 (ACPI data)
BIOS-e820: 00000000100a0000 - 00000000100b6e00 (reserved)
BIOS-e820: 00000000100b6e00 - 00000000100b7000 (ACPI NVS)
BIOS-e820: 00000000100b7000 - 0000000010100000 (reserved)
BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
255MB LOWMEM available.
ACPI: have wakeup address 0xc0001000
On node 0 totalpages: 65520
zone(0): 4096 pages.
zone(1): 61424 pages.
zone(2): 0 pages.
Kernel command line: vga=791 initrd=initrd.1024 acpi=off root=/dev/ram0 init=/linuxrc nomce BOOT_IMAGE=gentoo dopcmcia
Initializing CPU#0
Detected 366.603 MHz processor.
Console: colour dummy device 80x25
Calibrating delay loop... 730.72 BogoMIPS
Memory: 250996k/262080k available (1927k kernel code, 10696k reserved, 568k data, 104k init, 0k highmem)
Dentry cache hash table entries: 32768 (order: 6, 262144 bytes)
Inode cache hash table entries: 16384 (order: 5, 131072 bytes)
Mount-cache hash table entries: 4096 (order: 3, 32768 bytes)
Buffer-cache hash table entries: 16384 (order: 4, 65536 bytes)
Page-cache hash table entries: 65536 (order: 6, 262144 bytes)
Proc Config support by ptb@it.uc3m.es
proc config counted 6134 bytes in names
proc config counted 668 bytes in value handles
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 256K
CPU: After generic, caps: 0183f9ff 00000000 00000000 00000000
CPU: Common caps: 0183f9ff 00000000 00000000 00000000
CPU: Intel Mobile Pentium II stepping 0a
Enabling fast FPU save and restore... done.
Checking 'hlt' instruction... OK.
Checking for popad bug... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
ACPI: Subsystem revision 20021212
ACPI: Disabled via command line (acpi=off)
PCI: PCI BIOS revision 2.10 entry at 0xf1987, last bus=21
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: ACPI tables contain no PCI IRQ routing entries
PCI: Probing PCI hardware (bus 00)
PCI: Using IRQ router PIIX [8086/7110] at 00:05.0
PCI: Found IRQ 11 for device 00:0b.0
PCI: Found IRQ 11 for device 00:0b.1
PCI: Cannot allocate resource region 4 of device 00:05.1
Limiting direct PCI/PCI transfers.
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
Journalled Block Device driver loaded
devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x0
SGI XFS snapshot 2.4.20-2003-01-14_00:43_UTC with ACLs, DMAPI, realtime, quota, no debug enabled
vesafb: framebuffer at 0xdf000000, mapped to 0xd080d000, size 2496k
vesafb: mode is 1024x768x16, linelength=2048, pages=0
vesafb: protected mode interface info at c000:9da0
vesafb: scrolling: redraw
vesafb: directcolor: size=0:5:6:5, shift=0:11:5:0
Looking for splash picture.... found (1024x768, 12326 bytes).
Console: switching to colour frame buffer device 124x40
fb0: VESA VGA frame buffer device
pty: 256 Unix98 ptys configured
Real Time Clock Driver v1.10e
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PIIX4: IDE controller on PCI bus 00 dev 29
PIIX4: chipset revision 1
PIIX4: not 100% native mode: will probe irqs later
PIIX4: default first interface base=0x01f0, second interface base=0x170
ide0: BM-DMA at 0x1000-0x1007, BIOS settings: hda:DMA, hdb:pio
ide1: BM-DMA at 0x1008-0x100f, BIOS settings: hdc:DMA, hdd:pio
hda: TOSHIBA MK1517GAP, ATA DISK drive
hdc: DV-28E-A, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
blk: queue c03b3424, I/O limit 4095Mb (mask 0xffffffff)
hda: host protected area => 1
hda: 19640880 sectors (10056 MB), CHS=1222/255/63, UDMA(33)
hdc: ATAPI 24X DVD-ROM drive, 512kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
Partition check:
/dev/ide/host0/bus0/target0/lun0: p1 p2 p3 p4 < p5 p6 >
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
Equalizer1996: $Revision: 1.2.1 $ $Date: 1996/09/22 13:52:00 $ Simon Janes (simon@ncm.com)
SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
mice: PS/2 mouse device common for all mice
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
IP: routing cache hash table of 2048 buckets, 16Kbytes
TCP: Hash tables configured (established 16384 bind 32768)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
IPv6 v0.8 for NET4.0
IPv6 over IPv4 tunneling driver
RAMDISK: ext2 filesystem found at block 0
RAMDISK: Loading 5000 blocks [1 disk] into ram disk... done.
Freeing initrd memory: 5012k freed
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 104k freed
Linux PCMCIA Card Services 3.2.1
kernel build: 2.4.20-xfs-r2 #1 Thu Apr 10 02:24:31 Local time zone must be set--see zic manu
options: [pci] [cardbus] [apm]
Intel ISA/PCI/CardBus PCIC probe:
PCI: Found IRQ 11 for device 00:0b.0
PCI: Found IRQ 11 for device 00:0b.1
Toshiba ToPIC97 rev 05 PCI-to-CardBus at slot 00:0b, mem 0x10000000
host opts [0]: [slot 0xd0] [ccr 0x11] [cdr 0x86] [rcr 0x02] [pci irq 11] [lat 168/176] [bus 20/20]
host opts [1]: [slot 0xd0] [ccr 0x21] [cdr 0x86] [rcr 0x02] [pci irq 11] [lat 168/176] [bus 21/21]
ISA irqs (default) = 3,4,5,7,10,12 PCI status changes
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
uhci.c: USB Universal Host Controller Interface driver v1.1
PCI: Found IRQ 11 for device 00:05.2
uhci.c: USB UHCI at I/O 0xffe0, IRQ 11
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
usb.c: registered new driver hid
hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
hid-core.c: USB HID support drivers
Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
USB Mass Storage support registered.
ISO 9660 Extensions: Microsoft Joliet Level 3
ISO 9660 Extensions: RRIP_1991A
cloop: Welcome to cloop v0.68
cloop: /newroot/mnt/cdrom/livecd.cloop: 2032 blocks, 65536 bytes/block, largest block is 60876 bytes.
cloop: loaded (max 1 devices)
cs: cb_alloc(bus 21): vendor 0x10ec, device 0x8139
evms: EVMS v1.2.1 initializing .... info level(5).
evms: md raid5: measuring checksumming speed
evms: md raid5: 8regs : 606.000 MB/sec
evms: md raid5: 32regs : 354.800 MB/sec
evms: md raid5: pII_mmx : 830.400 MB/sec
evms: md raid5: p5_mmx : 867.200 MB/sec
evms: md raid5: using function: p5_mmx (867.200 MB/sec)
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI ISAPNP enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
inserting floppy driver for 2.4.20-xfs-r2
Floppy drive(s): fd0 is 1.44M
FDC 0 is an 8272A
apm: BIOS version 1.2 Flags 0x02 (Driver version 1.16)
cs: memory probe 0x0d0000-0x0dffff: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x220-0x22f 0x330-0x337 0x378-0x37f 0x388-0x38f 0x4d0-0x4d7
cs: IO port probe 0x0230-0x032f: clean.
cs: IO port probe 0x0338-0x0377: clean.
cs: IO port probe 0x0380-0x0387: clean.
cs: IO port probe 0x0390-0x04cf: clean.
cs: IO port probe 0x04d8-0x04ff: clean.
cs: IO port probe 0x0800-0x08ff: clean.
cs: IO port probe 0x0a00-0x0aff: clean.
cs: IO port probe 0x0c00-0x0cff: clean.
ttyS01 at port 0x02f8 (irq = 3) is a 16550A
8139too Fast Ethernet driver 0.9.26
PCI: No IRQ known for interrupt pin A of device . Please try using pci=biosirq.
8139too: : region #1 not an MMIO resource, aborting
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
8139cp: pci dev (id 10ec:8139 rev 10) is not an 8139C+ compatible chip
8139cp: Try the "8139too" driver instead.
irda_init()
PCI: Found IRQ 11 for device 00:09.0
PCI: Sharing IRQ 11 with 00:04.0
IrDA: Registered device irda0
ToshOboe: Using single tasks, version $Id: toshoboe.c,v 1.91 1999/06/29 14:21:06 root Exp $
8139too Fast Ethernet driver 0.9.26
PCI: No IRQ known for interrupt pin A of device . Please try using pci=biosirq.
8139too: : region #1 not an MMIO resource, aborting
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
8139cp: pci dev (id 10ec:8139 rev 10) is not an 8139C+ compatible chip
8139cp: Try the "8139too" driver instead.
8139too Fast Ethernet driver 0.9.26
PCI: No IRQ known for interrupt pin A of device . Please try using pci=biosirq.
8139too: : region #1 not an MMIO resource, aborting
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
8139cp: pci dev (id 10ec:8139 rev 10) is not an 8139C+ compatible chip
8139cp: Try the "8139too" driver instead.
8139too Fast Ethernet driver 0.9.26
PCI: No IRQ known for interrupt pin A of device . Please try using pci=biosirq.
8139too: : region #1 not an MMIO resource, aborting
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
8139cp: pci dev (id 10ec:8139 rev 10) is not an 8139C+ compatible chip
8139cp: Try the "8139too" driver instead.
8139too Fast Ethernet driver 0.9.26
PCI: No IRQ known for interrupt pin A of device . Please try using pci=biosirq.
8139too: : region #1 not an MMIO resource, aborting
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
8139cp: pci dev (id 10ec:8139 rev 10) is not an 8139C+ compatible chip
8139cp: Try the "8139too" driver instead.
8139too Fast Ethernet driver 0.9.26
PCI: No IRQ known for interrupt pin A of device . Please try using pci=biosirq.
8139too: : region #1 not an MMIO resource, aborting
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
8139cp: pci dev (id 10ec:8139 rev 10) is not an 8139C+ compatible chip
8139cp: Try the "8139too" driver instead.
8139too Fast Ethernet driver 0.9.26
PCI: No IRQ known for interrupt pin A of device . Please try using pci=biosirq.
8139too: : region #1 not an MMIO resource, aborting
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
8139cp: pci dev (id 10ec:8139 rev 10) is not an 8139C+ compatible chip
8139cp: Try the "8139too" driver instead.
8139too Fast Ethernet driver 0.9.26
PCI: No IRQ known for interrupt pin A of device . Please try using pci=biosirq.
8139too: : region #1 not an MMIO resource, aborting
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
8139cp: pci dev (id 10ec:8139 rev 10) is not an 8139C+ compatible chip
8139cp: Try the "8139too" driver instead.
8139too Fast Ethernet driver 0.9.26
PCI: No IRQ known for interrupt pin A of device . Please try using pci=biosirq.
8139too: : region #1 not an MMIO resource, aborting
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
8139cp: pci dev (id 10ec:8139 rev 10) is not an 8139C+ compatible chip
8139cp: Try the "8139too" driver instead.
usb-uhci.c: $Revision: 1.275 $ time 02:28:02 Apr 10 2003
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver


Ich habe diesmal nur mit Option dopcmcia gestartet.

mfG Stef

6

20.07.2003, 21:15

Re: Realtek 8139 & pcmcia

Zitat

Original von derstef

Hallo, ich versuche gerade Gentoo 1.4rc4 auf meinem Toshiba Tecra 8000 zu installieren und hänge bei der Netzwerkkonfiguration fest. Die pcmcia-Treiber habe ich beim Start schon geladen (dopcmcia). Will ich nun das 8139too-Modul laden bekomme ich die Fehlermeldung:
8139too: region #1 not an MMIO resource, aborting

Kann mir jemand weiterhelfen?

mfG Stef


Hallo,

hat sich denn in dieser Hinsicht etwas ergeben ? Ich hab nämlich ebenfalls eine PCMCIA-RTL8193 Karte - und damit das gleiche Problem...

Grüße Hurrz

7

20.07.2003, 22:15

Hi,

ich habe leider keine Lösung für das Problem gefunden. Habe das gute alte Redhat draufgemacht und die wichtigsten Sachen neu kompiliert - da kann Gentoo kaum schneller sein. Wenn du aber unbedingt Gentoo haben willst kann ich dir nur den Rat geben auf die Final zu warten - dann habens die Jungs vielleicht hinbekommen.

Grüße Stef

PS: kannst dich ja mal melden falls sich was ergibt

8

21.07.2003, 11:41

also, machst du als erstes "menuconfig" oder ähnliches an. gehst du zu "network device support". gehst du als nächstes zu "ethernet (10 or 100mbit)". suchst du da "realtek 8139 pci fast ethernet adapter support", und machst da drunter
[code:1]
&#91; &#93; use PIO instead of MMIO
[/code:1]
an. das sollte zumindest bei eurem jetzigen prob helfen. wenns dann noch nicht geht bitte ich um die nächste fehlermeldung... :shock:

sploenni

@derstef: es is volkommen egal welche version du dir installierst. nach einem "emerge sync" und einem "emerge -uD world" hat man immer die neuste version.... einer der vorteile von gentoo ist halt die grosse aktualität. und da kann auch kein redhat, suse, mdk und schon gar kein debian mithalten.

9

21.07.2003, 14:08

Hi,

das mit dem menuconfig ist doch aber fürs kompilieren des kernels, oder? Mit der live-stage3-cd geht das doch aber nicht, denn man braucht ja netzwerk um erstmal so weit zu kommen einen compiler zu haben.

mfg Stef

10

21.07.2003, 14:31

hm, das ist natürlich ein problem. hast du denn ne knoppix-cd oder ne andere möglichkeit ins netz zu kommen? dann könntest du dir den kernel (z.B. die gentoo-sources) und die anderen pakete fürs grundsystem (emerge -p system) als tar-ball runterladen und auf deiner platte ins verzeichnis "/usr/portage/distfiles" kopieren. dann kannst du mit "emerge system" dein grundsystem installieren. danach mit "emerge gentoo-sources" den kernel mergen, konfigurieren (die sache mit dem rtl8139 beachten!!!), und installieren. den bootmanager konfigurieren, neu starten, und ab ins netz... ist vielleicht ein wenig umständlich, sollte aber funktionieren

11

21.07.2003, 15:16

Hi,

das ist ne gute Idee, werd ich mal probieren wenn ich mehr Zeit hab (schreib grad Diplom). Werd dann bescheidsagen wenns geklappt hat.

Danke erstmal

Gruß Stef

12

21.07.2003, 19:46

na dann viel erfolg!

13

01.09.2003, 22:36

hab mir mal die Mühe (war eigentlich keine, nur dass ich eben knoppix gebootet hab) gemacht - und es funktioniert.
Unter knoppix das Grundsystem eingerichtet, gentoo-kernel
mit
[code:1]
&#91;x&#93; use PIO instead of MMIO[/code:1]
kompiliert, in die /etc/init.d/pcmcia noch das Laden des Modules eingetragen: [code:1]/sbin/modprobe 8139too[/code:1]
und alles läuft. :P