Sie sind nicht angemeldet.

1

15.10.2005, 23:47

Probleme mit CD-Laufwerken

Also gut, ich fang mal ganz von vorne an:
Ich habe bisher einen einzigen schäbigen alten CD-Brenner (/dev/hdc) gehabt, der aber nicht mehr zum Brennen geeignet war (selbstständig gemountet an /media/cdrecorder). So, jetzt habe ich mir aber einen neuen Brenner gekauft (/dev/hdd), der dann automatisch an /media/hdd gemountet wurde. Ich habe mir gedacht, was solls, ich will das ein bisschen anders haben, und in der fstab rumgespielt (in der hdd gar nicht aufgelistet war) Ich habe den hdc-Eintrag einfach kopiert, und die Namen geändert.
Wenn ich jetzt allerdings eine leere CD in den neuen Brenner einlege (der vor dieser Aktion mit dem Nautlius-Brenner gefunzt hat), kommt eine Fehlermeldung:

Quellcode

1
2
mount: block device /dev/hdd is write-protected, mounting read-only
mount: /dev/hdd: can't read superblock

Meine fstab:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
# <fs>			<mountpoint>	<type>		<opts>		<dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/hda3		/		reiserfs	defaults,notail	1 1
/dev/hda1		/windows	ntfs		utf8,umask=0222	0 2
/dev/hda5               /daten          vfat            users,utf8,umask=000  0 2
/dev/hda4		none		swap		sw		0 0
/dev/sda1               /mnt/usbstick	vfat		utf8,noauto,users	0 0
#/dev/fd0		/mnt/floppy	auto		noauto		0 0

# NOTE: The next line is critical for boot!
proc			/proc		proc		defaults	0 0

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for 
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
#  use almost no memory if not populated with files)
shm			/dev/shm	tmpfs		nodev,nosuid,noexec	0 0
/dev/hdc                /media/dvdrom		auto    users,exec,noauto,managed 0 0
/dev/hdd                /media/cdrecorder       auto    users,exec,noauto,managed 0 0
Und wie gesagt: Die hdd-Linie existierte vorher gar nicht, die hdc ist irgendwann mal automatisch generieret worden (vermutlich bei der Installation) .. es kommt mir jedenfalls komisch vor, da der oben erwähnte Fehler auch auftritt, wenn ich in hdc eine leere CD einlege, obwohl an DEREN Einstellungen nichts geändert habe ...
Wer zerschlägt den Gordischen Knoten ?(

Zusatz: hdc war vorher an /media/cdrecorder gemountet, da es aber eh nicht als Brenner funzt habe ich es in dvdrom umgeändert, und an der Stelle hdd dort gemountet ...
Wer früh aufsteht, hat mehr vom Tag! ;)

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Wuestenfuchs« (15.10.2005, 23:55)


2

16.10.2005, 00:19

Hi,

der Suberblock Fehler ist damit zu erklären, dass der Rohling den du einlegst noch gar keinen Superblock hat. Normalerweise wird dann von Gnome der Nautilus CDBrenner gestartet, das klappt aber jetzt nicht mehr. Ich denke der Rohling wird einfach nicht als Rohling erkannt. Vielleicht hat das mit den Pfaden zu tun, vielleicht auch mit den Einstellungen von Gnome.
Hast du gnome-volume-manager gemerged?
Hinter dir! Ein dreiköpfiger Affe!
rleyh's residence (homepage): [url]http://rleyh.1a.to[/url]

3

16.10.2005, 00:23

Natürlich ist der gnome-volume-manager installiert. Und noch gestern morgen wurde ein Rohling auch ganz selbstverständlich als "Blank Disk" erkannt ... ich weiß nicht, was dem da nicht passt ... Muss ich diesen Volume Manager vielleicht neu installieren ???
Wer früh aufsteht, hat mehr vom Tag! ;)

4

16.10.2005, 00:25

Probiers mal und schau nach ob du ihn richtig konfiguriert hast.
Weiter weiß ich auch nicht :(
Hinter dir! Ein dreiköpfiger Affe!
rleyh's residence (homepage): [url]http://rleyh.1a.to[/url]

5

16.10.2005, 00:31

Versuch mal, in der fstab für den neuen Brenner den selben Mount-Pfad anzugeben wie füher für den alten. Vielleicht ist dieser Pfad noch in irgendwelchen Gnome-Configdateien eingetragen.

6

18.10.2005, 21:34

DrKOks,

Nene Du, das hat nichts gebracht. Das war es ja was ich zuerst versucht habe und wobei die ganze Sache hops gegangen ist. Ich weiß echt nicht weiter. Im englischen Gentoo-Forum scheint man auch keine zufriedenstellende Antwort zu kennen. Aber es sieht sowieso nach einer Neuinstallation von Gentoo aus (ReiserFS am Arsch, Gnome nicht mehr ganz gesund und jetzt auch noch das ... ) Mal wieder zu neuen Ufern aufbrechen 8)
Wer früh aufsteht, hat mehr vom Tag! ;)

7

19.10.2005, 00:04

schau

vorher noch mal in die fstab, da sollte bei den optionen rw drinnenstehn, wenn keine defaults da sind, und schau dir die berechtigungen auf die datein /dev/hdc und /dev/hdd nochamal an.

eine frage noch in eigener sache: wie bitteschön hast du fstab automatisch bei gentoo generieren lassen? nehme mal an du hast einiges an linuxerfahrung, ich hab selbst schon xmal gentoo aufgesetzt aber die fstab automaisch erstellen wär ein geiles feature gewesen! tx 4 aw!
... nur ein weiterer tag im leben eines naren ... :P

8

19.10.2005, 00:22

RE: schau

Zitat

Original von capoeira
vorher noch mal in die fstab, da sollte bei den optionen rw drinnenstehn


rw brauchst du bei CD-Laufwerken nicht. Das bezieht sich bloß auf das gemountete Dateisystem und das ist bei CDs normalerweise nicht beschreibbar.

9

19.10.2005, 00:47

rw-option

interessanter aspekt UND klingt absolut logisch, hatte auch schon des öfteren ähnliche probs und hab dann bei debian nachgekuckt, ist immer wieder mal zweitsystem bei mir, dort stands drin, habs übernommen und hat gefunkt?
... nur ein weiterer tag im leben eines naren ... :P