Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

28.03.2006, 11:28

[gelöst] Probleme mit xorg-x11 nach Update

Hi,

Nachdem meine Grafikkarte (ATI Radeon 9700 SE) -> im System erkannt mit:

Quellcode

1
2
lspci
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]


nur wackelig läuft, habe ich versucht auf xorg-x11 Version 7 abzudaten und auch alle Pakete neu kompiliert. Leider lief die Karte dort garnicht und somit habe ich beschlossen nun wieder mit der Version 6.8 vorlieb zu nehmen.

soweit kein Problem,denn alles läuft, aber wenn ich nun versuche mein System mit

Quellcode

1
emerge -uDe world


neu zu kompilieren, dann bekomme ich bei dem Paket vino-2.12.0 folgendes Problem:

  1. Merging translations into vino-server.schemas.
    LC_ALL=C ../intltool-merge -o -u -c ../po/.intltool-merge-cache ../po GNOME_RemoteDesktop.server.in GNOME_RemoteDesktop.server
    Found cached translation database
    Merging translations into GNOME_RemoteDesktop.server.
    libtool: link: cannot find the library `/usr/lib/libXfixes.la'
    make[4]: *** [vino-server] Error 1
    rm GNOME_RemoteDesktop.server.in
    make[4]: Leaving directory `/mnt/Shared/portage/portage/vino-2.12.0/work/vino-2.12.0/server'
    make[3]: *** [all-recursive] Error 1
    make[3]: Leaving directory `/mnt/Shared/portage/portage/vino-2.12.0/work/vino-2.12.0/server'
    make[2]: *** [all] Error 2
    make[2]: Leaving directory `/mnt/Shared/portage/portage/vino-2.12.0/work/vino-2.12.0/server'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/mnt/Shared/portage/portage/vino-2.12.0/work/vino-2.12.0'
    make: *** [all] Error 2

    !!! ERROR: net-misc/vino-2.12.0 failed.
    Call stack:
    ebuild.sh, line 1526: Called dyn_compile
    ebuild.sh, line 923: Called src_compile
    ebuild.sh, line 1236: Called gnome2_src_compile
    gnome2.eclass, line 56: Called die

    !!! compile failure
    !!! If you need support, post the topmost build error, and the call stack if relevant.
    [/list=1]

    Die Library libXfixes, die libXfixes.la beinhaltet kann ich nicht emergen, da sie mit <=xorg-x11-6.9 geblockt wird.

    Was kann ich nun tun um diese versteckte Abhängigkeit zu der vorher installierent xorg-x11-7-Version wieder aufzulösen?

    Gitano

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Gitano« (28.03.2006, 12:26)


2

28.03.2006, 11:33

hmm abhänigkeiten sollten eigentlich mit

Quellcode

1
emerge --depclean


gelöst werden, aber sei vorsichtig, nicht das es dir sachen löscht die du noch brauchst.
Er wird dir eine Liste ausgeben wo drin steht was er alles lköschen möchte. Da kannst du dann schauen.

mfg


Apollo
In jedem noch so reinen Herzen existiert ein Ort des tiefsten Abgrundes. (C) Apollo '02

3

28.03.2006, 12:19

Hi Apollo,

bist du sicher, dass das unmergen von Paketen hilft, die geforderte Library wieder zu bekommen oder den Zugriff darauf anders zu verweisen?

Ach ja, ich sollte noch erwähnen, dass ein normales

Quellcode

1
emerge -uDp world

keine Pakete installieren will.

Naja, hier mal das Ergebnis von emerge -depclean:

  1. x11-misc/linuxwacom
    selected: 0.7.2
    protected: none
    omitted: none

    perl-core/Digest-MD5
    selected: 2.36
    protected: none
    omitted: none

    x11-drivers/xf86-input-elographics
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-input-magictouch
    selected: 1.0.0.5
    protected: none
    omitted: none

    media-fonts/font-bh-ttf
    selected: 1.0.0
    protected: none
    omitted: none

    virtual/libstdc++
    selected: 3.3
    protected: none
    omitted: none

    x11-libs/libXdamage
    selected: 1.0.2.2
    protected: none
    omitted: none

    perl-core/libnet
    selected: 1.19
    protected: none
    omitted: none

    x11-drivers/xf86-input-hyperpen
    selected: 1.0.0.5
    protected: none
    omitted: none

    perl-core/Test-Simple
    selected: 0.62
    protected: none
    omitted: none

    x11-apps/xmodmap
    selected: 1.0.0
    protected: none
    omitted: none

    x11-drivers/xf86-input-dynapro
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-input-keyboard
    selected: 1.0.1.3
    protected: none
    omitted: none

    media-fonts/font-adobe-utopia-type1
    selected: 1.0.1
    protected: none
    omitted: none

    x11-drivers/xf86-video-tseng
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-video-ark
    selected: 0.5.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-input-dmc
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-video-via
    selected: 0.1.33.2
    protected: none
    omitted: none

    x11-apps/setxkbmap
    selected: 1.0.2
    protected: none
    omitted: none

    x11-drivers/xf86-input-penmount
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-input-tek4957
    selected: 1.0.0.5
    protected: none
    omitted: none

    media-plugins/gst-plugins-esd
    selected: 0.8.11
    protected: none
    omitted: none

    x11-libs/libXp
    selected: 1.0.0
    protected: none
    omitted: none

    x11-drivers/xf86-input-acecad
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-libs/libXcomposite
    selected: 0.2.2.2
    protected: none
    omitted: none

    x11-drivers/xf86-input-magellan
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-input-summa
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-video-imstt
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-video-nsc
    selected: 2.7.6.5
    protected: none
    omitted: none

    x11-drivers/xf86-input-microtouch
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-input-ur98
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-video-cirrus
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-input-evdev
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-apps/xrandr
    selected: 1.0.1
    protected: none
    omitted: none

    app-doc/xorg-docs
    selected: 1.0.1
    protected: none
    omitted: none

    x11-drivers/xf86-video-glint
    selected: 1.0.1.3
    protected: none
    omitted: none

    perl-core/Test-Harness
    selected: 2.56
    protected: none
    omitted: none

    media-plugins/xmms-esd
    selected: 1.2.10-r1
    protected: none
    omitted: none

    x11-drivers/xf86-video-fbdev
    selected: 0.1.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-video-i740
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-libs/libXxf86dga
    selected: 1.0.0-r1
    protected: none
    omitted: none

    sys-libs/lib-compat
    selected: 1.4
    protected: none
    omitted: none

    dev-lang/tk
    selected: 8.4.11-r1
    protected: none
    omitted: none

    x11-apps/mesa-progs
    selected: 6.4.2
    protected: none
    omitted: none

    x11-drivers/xf86-video-ati
    selected: 6.5.7.3
    protected: none
    omitted: none

    x11-drivers/xf86-video-voodoo
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-video-sis
    selected: 0.8.1.3
    protected: none
    omitted: none

    x11-drivers/xf86-video-nv
    selected: 1.0.1.5
    protected: none
    omitted: none

    media-fonts/font-bitstream-type1
    selected: 1.0.0
    protected: none
    omitted: none

    x11-drivers/xf86-input-spaceorb
    selected: 1.0.0.5
    protected: none
    omitted: none

    perl-core/DB_File
    selected: 1.814
    protected: none
    omitted: none

    x11-drivers/xf86-video-mga
    selected: 1.2.1.3
    protected: none
    omitted: none

    dev-java/commons-cli
    selected: 1.0-r4
    protected: none
    omitted: none

    x11-drivers/xf86-input-palmax
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-input-elo2300
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-input-jamstudio
    selected: 1.0.0.5
    protected: none
    omitted: none

    dev-java/commons-lang
    selected: 2.0-r1
    protected: none
    omitted: none

    x11-drivers/xf86-video-i128
    selected: 1.1.0.5
    protected: none
    omitted: none

    x11-drivers/synaptics
    selected: 0.14.4-r2
    protected: none
    omitted: none

    x11-drivers/xf86-video-vmware
    selected: 10.12.0.0
    protected: none
    omitted: none

    x11-drivers/xf86-video-neomagic
    selected: 1.0.0.5
    protected: none
    omitted: none

    perl-core/PodParser
    selected: 1.32
    protected: none
    omitted: none

    x11-drivers/xf86-input-citron
    selected: 2.1.5
    protected: none
    omitted: none

    x11-drivers/xf86-video-s3
    selected: 0.3.5.5
    protected: none
    omitted: none

    media-sound/madplay
    selected: 0.15.2b
    protected: none
    omitted: none

    x11-drivers/xf86-input-void
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-input-digitaledge
    selected: 1.0.1.3
    protected: none
    omitted: none

    perl-core/Time-HiRes
    selected: 1.86
    protected: none
    omitted: none

    x11-misc/xkeyboard-config
    selected: 0.7-r2
    protected: none
    omitted: none

    x11-drivers/xf86-video-savage
    selected: 2.0.2.3
    protected: none
    omitted: none

    media-fonts/font-adobe-100dpi
    selected: 1.0.0
    protected: none
    omitted: none

    x11-libs/libXvMC
    selected: 1.0.1-r1
    protected: none
    omitted: none

    x11-drivers/xf86-video-rendition
    selected: 4.0.1.3
    protected: none
    omitted: none

    x11-drivers/xf86-input-fpit
    selected: 1.0.0.5
    protected: none
    omitted: none

    dev-java/xml-commons
    selected: 1.0_beta2
    protected: none
    omitted: none

    x11-drivers/xf86-input-joystick
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-input-vmmouse
    selected: 12.3.1.0
    protected: none
    omitted: none

    x11-drivers/xf86-video-cyrix
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-video-chips
    selected: 1.0.1.3
    protected: none
    omitted: none

    sys-apps/ed
    selected: 0.2-r6
    protected: none
    omitted: none

    media-libs/t1lib
    selected: 5.0.2
    protected: none
    omitted: none

    x11-drivers/xf86-video-dummy
    selected: 0.1.0.5
    protected: none
    omitted: none

    dev-libs/gmp
    selected: 4.1.4-r3
    protected: none
    omitted: none

    perl-core/Storable
    selected: 2.15
    protected: none
    omitted: none

    x11-drivers/xf86-video-s3virge
    selected: 1.8.6.5
    protected: none
    omitted: none

    dev-libs/mpfr
    selected: 2.2.0_p8
    protected: none
    omitted: none

    x11-drivers/xf86-video-trident
    selected: 1.0.1.3
    protected: none
    omitted: none

    x11-drivers/xf86-video-v4l
    selected: 0.0.1.5
    protected: none
    omitted: none

    x11-drivers/xf86-video-vesa
    selected: 1.0.1.3
    protected: none
    omitted: none

    x11-drivers/xf86-video-tga
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-video-tdfx
    selected: 1.1.1.3
    protected: none
    omitted: none

    x11-drivers/xf86-video-sisusb
    selected: 0.7.1.3
    protected: none
    omitted: none

    x11-drivers/xf86-input-aiptek
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-video-vga
    selected: 4.0.0.5
    protected: none
    omitted: none

    x11-apps/xhost
    selected: 1.0.0
    protected: none
    omitted: none

    x11-drivers/xf86-input-calcomp
    selected: 1.0.0.5
    protected: none
    omitted: none

    perl-core/MIME-Base64
    selected: 3.07
    protected: none
    omitted: none

    x11-drivers/xf86-video-siliconmotion
    selected: 1.3.1.5
    protected: none
    omitted: none

    x11-drivers/xf86-input-mutouch
    selected: 1.0.0.5
    protected: none
    omitted: none

    x11-drivers/xf86-video-apm
    selected: 1.0.1.5
    protected: none
    omitted: none

    x11-drivers/xf86-input-mouse
    selected: 1.0.4
    protected: none
    omitted: none

    x11-drivers/xf86-video-i810
    selected: 1.4.1.3
    protected: none
    omitted: none

    media-plugins/gst-plugins-flac
    selected: 0.8.11
    protected: none
    omitted: none

    >>> 'Selected' packages are slated for removal.
    >>> 'Protected' and 'omitted' packages will not be removed.
    [/list=1]

    Was würdest du denn da unmergen?

    Gitano

4

28.03.2006, 12:31

Habs jetzt,

Hab alle Pakete mit x11-libs/libX* vom System geschmissen. Das Paket Vivo ließ sich nun emergen. Werd nun nochmal emerge -uDe world laufen lassen.

Danke Apollo, weiter so ;-)

Gitano

5

28.03.2006, 12:34

Keine Ursache :) dafür is das Forum ja da :)

mfg

Apollo
In jedem noch so reinen Herzen existiert ein Ort des tiefsten Abgrundes. (C) Apollo '02

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »Apollo« (28.03.2006, 12:39)