Sie sind nicht angemeldet.

1

09.04.2006, 23:57

Fluxbox Transparenz funktioniert nicht

Aus irgendeinem Grunde funktioniert die "unechte" Transparenz unter Fluxbox nicht mehr - jedenfalls halbwegs. Denn die Fenster werden, je größer die Transparenz, immer dunkler, als hätte ich ein schwarzes Wallpaper im Hintergrund.
Das steht in meiner .xinitrc:

Quellcode

1
startfluxbox & fbsetbg -c /home/azi/Wallpaper/Aqua_Genetk_by_darkex.jpg & /usr/libexec/gnome-settings-daemon

2

10.04.2006, 12:44

Jetzt habe ich fluxbox aktualisiert, jetzt lässt sich das Hintergrundbild überhauptnichtmehr ändern. Es ist nun immer Grün, und oben steht "There is no background option specified in this style. Please consult manual or read the FAQ." Super, aber in meinm Style IST ein Hintergrund definiert!

Quellcode

1
!rootCommand:	                fbsetbg -c /home/azi/Wallpaper/Aqua_Genetk_by_darkex.jpg

3

10.04.2006, 12:51

Wenn noch keiner auf deinen Beitrag geantwortet hat, dann gehe dort auf ändern und mache keinen neuen.
Nun aber zu deinem Problem:

Zitat

"There is no background option specified in this style. Please consult manual or read the FAQ."

Wenn wir nun schauen, was sich in der 0.15 geändert hat:
http://fluxbox.sourceforge.net/version-0.9.php
Kleiner Auszug:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
    * New theme item:
       * background: [texture option]
       * background.pixmap: image filename
       * background.color: [color]
       * background.colorTo: [color]
       The background.pixmap filename will be sent to "fbsetbg"
       which in turn sets the background.
       The following options will be available for the background.pixmap:
         - tiled 
         - centered
       For example:
         background: tiled
         background.pixmap: someimage.png
       and it can also generate a normal texture:
         background: gradient
         background.color: blue
         background.colorTo: green
       The rootCommand in the style is now obsolete and if the 
       "background" item is not found in the style then the default
       background will be green and with a warning text.

Also einfach im Style den Hintergrund richtig setzen, fertig!
"Erst nachdem wir alles verloren haben, haben wir die Freiheit, alles zu tun."
"It's only after we've lost everything, that we're free to do anything!"

Jabber: Die ID kann via PN erfragt werden.

4

10.04.2006, 13:08

Entschuldigung, das mit dem Editieren hatte ich vergessen!
Ja, nun klappt das mit dem Hintergrund schon besser, das Problem wurde aber nur 3/4 gelöst; aterm zeigt mir nun schön mein Hintergrundbild, aber Fluxbox selbst hat die Transparenz noch nicht verstanden. Es verhält sich immernoch so, als ob ich ein schwarzes Hintergrundbild gesetzt hätte...

5

10.04.2006, 13:12

Gut, die (unechte) Transparenz bei aterm, da weiß ich was du meinst, aber welche bei Fluxbox allgemein. Helf mir doch mal auf die Sprünge, dann werd ichs mir anschauen.
Was machst du? - Was macht der Rechner?
"Erst nachdem wir alles verloren haben, haben wir die Freiheit, alles zu tun."
"It's only after we've lost everything, that we're free to do anything!"

Jabber: Die ID kann via PN erfragt werden.

6

10.04.2006, 13:21

Man kann ja z.B. bei dem Menü oder der Toolbar die "unechte" Transparenz einstellen. Aber je niedriger ich den Alpha-Wert setze, desto dunkler wird das Menü. Als hätte ich als Hintergrundbild ein komplett schwarzes Bild. Klar?

7

10.04.2006, 13:48

Alles klar:
Bei mir steht im Style:

Zitat

background: flat
background.pixmap: /home/maggu2810/bilder/wallpaper.jpg

Dann setz ich den Alpha Wert mal auf 0, mache ein "reload config" und es passt eigentlich. Der mittlere Teil der Leiste, wo die Tasks erscheinen, noch nicht so ganz (da ist nur der aktive transparent), aber ich denke das liegt nur am Style, da die Uhr und die Anzeige um welche Arbeitsfläche es sich handel (und jeweils die 2 Pfeile) transparent dargestellt werden.
"Erst nachdem wir alles verloren haben, haben wir die Freiheit, alles zu tun."
"It's only after we've lost everything, that we're free to do anything!"

Jabber: Die ID kann via PN erfragt werden.

8

10.04.2006, 13:52

Bei mir steht folgendes:

Quellcode

1
2
         background: centered
         background.pixmap: /home/azi/Wallpaper/Aqua_Genetk_by_darkex.jpg

Aber ich kann so viele Alpha-Werte einstellen, wie ich will, die Config 20 mal reloaden, es tut sich nichts (bis auf die änderung der Dunkelheit). Ich werde mal rebooten (auch, wenn ich denke, dass dies nichts bringt)...

Ja, hat net geklappt, ich setzt mal einen Screenshot rein.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Azi« (10.04.2006, 14:00)


9

10.04.2006, 22:55

sry das ich auf diesen thread antworte - aber das wallpaper würde mich interessieren ;)
meinst du, du könntest es mir irgendwo hochladen ?(
danke schonmal im voraus!
MfG MyD

10

11.04.2006, 00:37

Hi Azi,
schau mal in deine .fluxbox/init, was steht da bei "session.forcePseudoTransparency: "?
Wenn dahinter 'false' steht, dann beende mal deine fluxbox-session - setzt den Wert auf 'true' und starte fluxbox wieder neu. Das könnte evt. helfen.
Gruss

11

11.04.2006, 14:02

@MyD
Schau mal unter http://www.aquanasoft.de/Wallpaper, dort hab ich es geuploadet. Es heißt "Aqua_Genetk_by_darkex.jpg". Eventuell werd ich in nächster Zeit noch meine anderen reinpacken :)

@randy
Klappt leider nicht...

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Azi« (11.04.2006, 14:24)