Sie sind nicht angemeldet.

Suchergebnisse

Suchergebnisse 1-20 von insgesamt 22.

07.01.2012, 22:13

Forenbeitrag von: »hcx«

File "/usr/lib/portage/pym/portage.py", line 889, in addProfile raise portage_exception.ParseError( NameError: global name 'parents_file' is not defined

Hallo, ich google mir schon seit tagen die finger wund nach einer Lösung für mein Problem. Nach einem Quellcode 1 FEATURES="-sandbox" ARCH="arm" emerge -avuDN portage und Quellcode 1 nohup emerge-webrsync gefolgt von Quellcode 1 emerge --skipfirst wegen sandbox wird jeder Aufruf von emerge jetzt mit: Quellcode 1 2 3 4 5 6 7 8 9 10 11 12 13 14 Traceback (most recent call last): File "/usr/bin/emerge", line 4049, in ? emerge_main() File "/usr/bin/emerge", line 3768, in emerge_main settings, trees,...

22.12.2011, 19:18

Forenbeitrag von: »hcx«

Your current system

Hallo Bell, stimmt ein neueres Portage als dieses habe ich nicht gefunden. eselect profile list funktioniet zwar doch setze ich das richtige profil armv5te server schreit emerge sofort No ARCH SET .....usw also lassen, Aber Python bekomme ich nicht geupgraded ! Quellcode 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 !! ERROR: dev-lang/python-2.6.6-r2 failed. !!! Function inherit, Line 1444, Exitcode 1 !!! died sourcing /usr/portage/eclass/user.eclass in inherit() !!!...

22.12.2011, 14:57

Forenbeitrag von: »hcx«

!!! Your current profile is deprecated and not supported anymore. !!! Please upgrade to the following profile if possible: uclibc/arm/2.4

Hallo, ich brauche mal wieder eure Hilfe ich kome nicht weiter. Ich habe nach langer Fummelei portage auf meiner NSLU2 halbwegs ans Laufen bekommen. Doch es läuft noch nicht richtig rund. Quellcode 1 uname -a 2.6.16 #1 PREEMPT Fri Jun 9 07:34:31 PDT 2006 armv5teb XScale-IXP42x Family rev 2 (v5b) Linksys NSLU2 GNU/Linux am Laufen und portage-latest nach /mnt/gentoo/usr entpackt. mein Systemlink auf make.profile sieht so aus: Quellcode 1 arm -> /usr/portage/profiles/uclibc/arm/ In meiner make.onf ...

20.12.2011, 18:22

Forenbeitrag von: »hcx«

Portage reparieren

Hallo Planshift, ich habe ein ähnliches Problem. Ich versuche set Wochen ein Gentoo stage3-armeb-uclibc-2005.1. auf meiner NSLU2 ans Laufen zu bekommen. http://www.gentooforum.de/artikel/20255/emerge-auf-einer-nslu2.html? Alle Vorschläge und Tipps haben leider nicht geholfen Portag dazu zu bewegen zu funktionieren. Deshalb habe ich unter /mnt/gentoo ein Verzeicnis gentto angelegt und dort Python-2.7.2.tar.bz2 portage-latest.tar.bz2 abgelegt und nach /mnt/gentoo/usr/portage/packages entpackt was ...

19.12.2011, 18:33

Forenbeitrag von: »hcx«

Noch'n Experiment

Hallo Bell, Hallo Dyle, dieses Portage ging mir mächtig auf den ..... also habe ich es mal anders versucht und gentoo mit der Live CD in einer Virtualbox installiert. Dazu Portage-2.2.0_alpha80 mittels Quellcode 1 emerge --sync Quellcode 1 emerge --update --ask world und Quellcode 1 emerge --update --deep --newuse world auf Version 2.1.10.11 gebracht Als Profil Quellcode 1 hardened/linux/x86/selinux wegen nginx webserver (emerge empfahl dies so zu tun) Python-2.7 was ich unter /root ausserhalb d...

13.12.2011, 20:39

Forenbeitrag von: »hcx«

Neues Experiment

Hallo Bell, ich habe kein Debian mehr auf der Slug dennoch mal Python-2.7 versucht zu installieren, was jedoch mit dieser Fehlermeldung abbricht: Quellcode 1 2 3 4 5 6 running build running build_ext building dbm using gdbm INFO: Can't locate Tcl/Tk libs and/or headers ./python: can't resolve symbol 'round' make: *** [sharedmods] Error 1 Python ist also weiterhin 2.3.5 Die Pfade habe ich so gesetzt: Quellcode 1 2 3 4 5 $PATH bash: /root/portage-2.1.10.11/bin/:/usr/local/bin:/usr/bin:/bin:/usr/lo...

11.12.2011, 16:38

Forenbeitrag von: »hcx«

stage1-armeb-uclibc-softfloat-2005.1 emerge syntax error

Hallo bell und dyle, zu Experiment 1 gnuaebi - das Stagearchiv lässt sich nicht auf der Hardware armv5teb XScale-IXP42x Family rev 2 (v5b) ausführen zu Experiment 2 stage 1 Archiv auch hier hängt alles an emerge: Quellcode 1 2 3 4 5 6 7 8 emerge --sync Traceback (most recent call last): File "/usr/bin/emerge", line 10, in ? import portage File "/usr/lib/portage/pym/portage/__init__.py", line 36 except ImportError as e: ^ SyntaxError: invalid syntax meine make.conf habe ich gemäss des HOWTOs ents...

10.12.2011, 18:14

Forenbeitrag von: »hcx«

emerge auf einer NSLU2

Hallo bell, das mit crossdev wäre natürlich eine nummer . Debian nutze ich bereits seit 2.2 und hatte squeeze schon auf der SLUG am laufen. Der Installer ist very buggy, da gefiel mir das turnup script von Gentoo schon besser. Un dieses emerge soll angeblich laufen (http://forums.gentoo.org/viewtopic-t-832…e76c10869a25e61 Ich post meine Errors mal an l3u, mal sehen was der meint. Danke für Alles hcx

10.12.2011, 12:49

Forenbeitrag von: »hcx«

Python Version 2.4.4 lässt sich nicht installieren

Hallo bell, "Es gibt keine dummen Fragen, es gibt jedoch saudumme Antworten!" - mein alter Lehrmeister Ich hoffe diese ist nicht saudumm: Quellcode 1 2 3 4 5 6 cd usr/ .keep libexec/ share/ armeb-softfloat-linux-uclibc/ local/ src/ bin/ portage/ tmp/ include/ portage-2.1.6/ lib/ sbin/ ./python --version bringt als Rückmeldung : Quellcode 1 2 3 4 5 6 7 8 Unknown option: -- usage: ./python [option] ... [-c cmd | -m mod | file | -] [arg] ... Try `python -h' for more information.[/code} doch mit pyt...

09.12.2011, 18:04

Forenbeitrag von: »hcx«

./python: can't open file '/usr/portage-2.6.1/bin/emerge': [Errno 2] No such file or directory

Hallo bell, in Python-2.4.4 sind: Quellcode 1 2 3 4 Demo LICENSE Makefile.pre Objects Python aclocal.m4 config.status libpython2.4.a python Doc Lib Makefile.pre.in PC README build configure platform setup.py Grammar Mac Misc PCbuild RISCOS buildno configure.in pyconfig.h Include Makefile Modules Parser Tools config.log install-sh pyconfig.h.in Quellcode 1 2 3 4 Python-2.4.4 # ./python /usr/portage-2.6.1/bin/emerge python --info ./python: can't open file '/usr/portage-2.6.1/bin/emerge': [Errno 2]...

09.12.2011, 17:29

Forenbeitrag von: »hcx«

./python /usr/portage-2.6.1/bin/emerge python bash: ./python: No such file or directory

Servus bell, danke für die tolle Anleitung ich habe Python-2.4.4 wie beschrieben installiert, entpackt und kompiliert und dann den Aufruf Quellcode 1 ./python /usr/portage-2.6.1/bin/emerge python direkt aus dem Verzeichnis Python-2.4.4 gestartet doch den Pfad Quellcode 1 /usr/portage-2.1.6/bin/emerge python gibt es so wenig wie Quellcode 1 /usr/portage/bin/ emerge python which emerge zeigt nach wie vor auf /usr/bin/emerge und python zeigt an: Quellcode 1 Python 2.3.5 (#1, Aug 21 2005, 16:01:57) ...

09.12.2011, 14:26

Forenbeitrag von: »hcx«

Ah jetzt ja - na fast jedenfalls

Servus bell, soweit kapiert also habe ich in der chroot Umgebung die Befehle: Quellcode 1 export PYTHONPATH="/usr/portage-2.6.1/pym:${PYTHONPATH}" und Quellcode 1 export PATH="/usr/portage-2.6.1/bin:${PATH}" abgesetzt so daß Quellcode 1 echo $PATH nun zurückliefert: Quellcode 1 /usr/portage-2.6.1/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin: und Quellcode 1 echo $PYTHONPATH Quellcode 1 /usr/portage-2.6.1/pym: Quellcode 1 which emerge gibt als Rückgabe Quellcode 1 /usr/bin/eme...

08.12.2011, 22:42

Forenbeitrag von: »hcx«

Portage version stimmt noch immer nicht trotz export

Servus bell, ok soweit verstanden. portage-latest habe ich neu installiert und nun gibt es auch /profiles/default/linux/arm/10.0 make.profiles stimmt nun auch denoch sttimmt die portage-version noch immer nicht Quellcode 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 Gentoo Base System version 1.6.13 Portage 2.0.51.22-r2 (default/linux...

08.12.2011, 16:06

Forenbeitrag von: »hcx«

Rettungs Portage export PYTHON PATH eselect

Servus Bell, danke erstmal für deine sehr wertvollen Tipps. Also ich habe jetzt den link make.profile unter Quellcode 1 /mnt/gentoo/etc auf /usr/portage/profiles/default/linux/arm/10.0 gelegt doch den Pfad /usr/portage/profiles/default/linux/arm/10.0 kann ich nirgends finden bei mir gibt es den nicht sondern nur ein Quellcode 1 /usr/portage-2.1.6 jedoch kein /profiles/default/linux Nur zur Verdeutlichung von wegen Und falls irgendwo Schwierigkeiten sind, bitte die Fehlermeldung posten, damit wir...

07.12.2011, 20:18

Forenbeitrag von: »hcx«

Portage auf 2.1.6 bringen usw.

Hallo Bell, sorry ich bin momentan sehr im Stress weshalb ich die Tags nicht mit dem Editor sondern mit dem vi zusammengekloppt habe. deine Beiträge habe ich nicht bewusst überlesen schon gar nicht um dich zu ärgern sondern schlichtweg nicht richtig verstanden und ich wollte dich nicht mit zu vielen Fragen nerven - Gentoo ist Neuland für mich. Ok die packages.keywords stimmt jetzt syntaktisch Quellcode 1 =sys-libs/ncurses-5.2-r2 doch Portage aud 2.1.6 zu bringen wie in Beitrag 6 beschrieben hat ...

06.12.2011, 21:14

Forenbeitrag von: »hcx«

emerge auf einer NSLU2

Hallo Bell, mea maxima culpa ich weiss ich bin eine Code Schlampe und gelobe Besserung. ich will versuchen deine Fragen zu beantworten so wie ich sie verstanden habe: ]/etc/portage/package.keywords habe ich wie folgt geändert ich hoffe es ist jetzt so richtig: Quellcode 1 =+sys-libs/ncurses-5.2-r2 python Version ist: Python 2.3.5 (#1, Aug 21 2005, 16:01:57) GCC 3.4.4 (Gentoo 3.4.4, ssp-3.4.4-1.0, pie-8.7.] on linux2 Portage ist Version: emerge --version Portage 2.0.51.22-r2 (uclibc/arm/2.4, gcc-...

05.12.2011, 18:30

Forenbeitrag von: »hcx«

Portage läuft nun aber emerge will immer noch nicht aud der NSLU2

Hallo zusammen, so zuerst die gute Nachricht Portage habe ich installiert bekommen. Nun die schlechten: Quellcode 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 emerge -epvDN world Invalid atom in /etc/portage/package.keywords: =dev-perl/Shell-EnvImporter !!! If you need support, post the topmost build error, NOT this status message. aux_get(): (0) Error in sys-apps/grep-2.5.4-r1 ebuild. (1) Check for syntax error or corruption in the ebuild. (--d...

24.11.2011, 19:48

Forenbeitrag von: »hcx«

emerge auf einer NSLU2

Hallo bell, bin ich dabei lösche eben /mnt/gentoo und spiel des stage3 archiv neu ein Gruss hcx

24.11.2011, 16:14

Forenbeitrag von: »hcx«

emerge auf einer NSLU2

Hallo Dyle, Danke erstmal für deine Hilfe. Python ist Python 2.3.5 (#1, Aug 21 2005, 16:01:57) die make conf schaut un gemaß http://www.gentoo-wiki.info/Gentoo_on_NSLU2 so aus: CFLAGS="-march=armv5t -Os" CHOST="armeb-softfloat-linux-uclibc" CXXFLAGS="-march=armv5t -Os" USE="pam -bitmap-fonts -truetype-fonts -type1-fonts -expat" PORTAGE_RSYNC_EXTRA_OPTS="--exclude-from=/etc/portage/rsync_excludes" RSYNC_TIMEOUT=500 FEATURES="ccache -noman -noinfo -nodoc" UCLIBC_CPU="ARM_XSCALE" Allerdings habe ic...

23.11.2011, 16:03

Forenbeitrag von: »hcx«

emerge-problem Pthon

Hallo bell und dyle, also ich habe es diesmal mit einem 2007-er Portage versucht : portage-2007.0.tar.bz2 eselect: command not found emerge wie bisher: emerge -av portage pam File "/usr/bin/emerge", line 44 except PermissionDenied as e: ein noch älteres portage habe ich nicht gefunden. Gruss und Danke hcx